AllegroGL is now part of the Allegro 4.3.x development series (Allegro 4.4 stable). We suggest using that version if you want to use OpenGL with Allegro 4. If for some reason you are still using Allegro 4.2.x and don't want to upgrade, you can still get the latest standalone AllegroGL from the SourceForge download page.

The Allegro 5 development series also comes with full OpenGL support.